Package Details: libimobiledevice-git 1:1.2.0.r52.g45fda81-2

Git Clone URL: https://aur.archlinux.org/libimobiledevice-git.git (read-only)
Package Base: libimobiledevice-git
Description: libimobiledevice is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux
Upstream URL: http://www.libimobiledevice.org/
Licenses: GPL2, LGPL2.1
Conflicts: libimobiledevice, libiphone, libiphone-git
Provides: libimobiledevice, libiphone, libiphone-git
Submitter: None
Maintainer: intelfx
Last Packager: intelfx
Votes: 60
Popularity: 1.380438
First Submitted: 2010-03-25 16:57
Last Updated: 2017-02-06 01:59

Required by (23)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

intelfx commented on 2013-11-14 16:20

Here we go again... (please take a look at usbmuxd-git comments if you didn't)

- PYTHON=python2 given instead of disabling cython (for minimal deviation from official package)
- libusbmuxd-git dependency moved to usbmuxd-git
- provides=(... "libimobiledevice=1.2") is wrong since the version (as in config.h) is 1.1.6

ftp://intelfx.dyndns.org/libimobiledevice-git-1:1.1.0.406.g3c3a791-2.src.tar.gz

intelfx commented on 2013-10-20 21:19

Could you please update the PKGBUILD? A better pkgver() can be used, libplist may be replaced with libplist-git and there is a couple of fixes to the build process...

You can find the updated package here:
ftp://intelfx.dyndns.org/libimobiledevice-git-1:1.1.0.353.gc7c49ae-1.src.tar.gz

nac2013 commented on 2013-10-06 06:14

which version is this ? the one in the git is 1.1.6
>>nathan:[~/libi/libimobiledevice]$ cat ./configure.ac
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.

AC_PREREQ(2.61)
AC_INIT(libimobiledevice, 1.1.6, nospam@nowhere.com)
---
and thogh i have python 3 installed it keeps giving me
configure: error: in `/home/nathan/libi/libimobiledevice':
configure: error:
This version of the AC_PYTHON_DEVEL macro
doesn't work properly with versions of Python before
2.1.0. You may need to re-run configure, setting the
variables PYTHON_CPPFLAGS, PYTHON_LDFLAGS, PYTHON_SITE_PKG,
PYTHON_EXTRA_LIBS and PYTHON_EXTRA_LDFLAGS by hand.
Moreover, to disable this check, set PYTHON_NOVERSIONCHECK
to something else than an empty string.

See `config.log' for more details
>>nathan:[~/libi/libimobiledevice]$ python
Python 3.3.2 (default, Sep 6 2013, 09:35:59)
[GCC 4.8.1 20130725 (prerelease)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys, string;
>>> ver = string.split(sys.version)[0];
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
AttributeError: 'module' object has no attribute 'split'
>>>
found the split is causing the error for some reason , help ?

Anonymous comment on 2013-04-26 15:31

Still breaks upower - after i install libimobiledevice-git and restart, systemd stops because of upower problems.

alexbrinister commented on 2013-04-11 22:41

Fixed.

jft commented on 2013-04-11 20:59

Breaks upower and thus gnome3 currently. upower depends on /usr/lib/libimobiledevice.so.3 but but this package provides /usr/lib/libimobiledevice.so.4.

oriba commented on 2012-12-16 03:31

ah, the usbmuxd-git in the deen ds is nt necessary, because there already is usbmuxd available via pacman.
But as I now saw, libimobiledevice itself also is available via pacman.
Thats nice :-)
But it would be better if this would be mentioned on AUR, it took my a while until - by chance - found it out....

gpain commented on 2012-07-31 22:02

Thanks a lot mtwomey!
You were right, I needed to install libtool and everything went like a charm.

Anonymous comment on 2012-07-31 02:11

@gpain I had this exact same issue. Turns out I was missing libtool (this was noted near the beginning of the build process).

sebikul commented on 2012-07-19 00:08

@gpain: It builds just fine on a clean chroot. Could you be more specific please?

Anyway, I updated the PKGBUILD to remove some unused features.