Package Details: pantheon-music-git 5.0.5.r94.gb09e38ef-1

Git Clone URL: https://aur.archlinux.org/pantheon-music-git.git (read-only, click to copy)
Package Base: pantheon-music-git
Description: The Pantheon Music Player
Upstream URL: https://github.com/elementary/music
Licenses: GPL3
Conflicts: pantheon-music
Provides: pantheon-music
Submitter: alucryd
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 23
Popularity: 0.000003
First Submitted: 2017-05-01 14:36 (UTC)
Last Updated: 2021-02-21 04:22 (UTC)

Latest Comments

PedroHLC commented on 2019-07-18 19:13 (UTC)

@alucryd Thank you! :D

alucryd commented on 2019-07-18 10:30 (UTC)

Should be all good now!

PedroHLC commented on 2019-05-07 02:05 (UTC)

plugins/LastFM/meson.build:1:0: ?[1;31mERROR:?[0m Dependency "libsignon-glib" not found, tried pkgconfig and cmake

Still getting this with clean chroot, both {g,}signon-glib are required.

alucryd commented on 2019-03-06 13:13 (UTC)

Missed the g indeed, it appears to be pulled by something else now.

PedroHLC commented on 2019-01-07 16:29 (UTC)

@alucryd I'm building from clean chroot and I'm also getting:

Dependency libsignon-glib found: NO (tried pkgconfig and cmake)

plugins/LastFM/meson.build:1:0: ERROR:  Dependency "libsignon-glib" not found, tried pkgconfig and cmake

I see that you added community's "libgsignon-glib" pkg as deps, but what about "libsignon-glib"??

alucryd commented on 2018-11-01 08:52 (UTC)

That dep is already in depends and it works fine here. How did you build it?

cguenther commented on 2018-10-30 00:16 (UTC)

some dependency is missing:

Dependency libsignon-glib found: NO (tried pkgconfig) plugins/LastFM/meson.build:1:0: ERROR: Dependency "libsignon-glib" not found, tried pkgconfig

alucryd commented on 2016-03-19 15:40 (UTC)

Forgot to merge into noise-player-bzr.

Yoshi2889 commented on 2016-03-19 15:39 (UTC)

This package fails to build because the patches it tries to apply point to nonexistent files or code.

alucryd commented on 2015-04-13 09:45 (UTC)

You'll have to rebuild granite-bzr against the new gtk that landed in extra, then rebuild audience which should work properly.

Softwayer commented on 2015-04-12 17:06 (UTC)

Actually, after building it doesn’t work properly anyway: [_LOG_LEVEL_FATAL 20:02:33.078136] [GLib-GObject] g_object_set: assertion 'G_IS_OBJECT (object)' failed [_LOG_LEVEL_FATAL 20:02:33.078168] Audience will not function properly. [_LOG_LEVEL_FATAL 20:02:33.083603] [GLib-GObject] g_object_set: assertion 'G_IS_OBJECT (object)' failed [_LOG_LEVEL_FATAL 20:02:33.083641] Audience will not function properly.

Softwayer commented on 2015-04-12 17:03 (UTC)

I cannot build it: ** (valac:13413): CRITICAL **: vala_data_type_copy: assertion 'self != NULL' failed /tmp/yaourt-tmp-ignat/aur-audience-bzr/src/audience/src/Audience.vala:237.42-237.70: error: The name `get_button_from_index' does not exist in the context of `Granite.Widgets.Welcome' var button = welcome.get_button_from_index (2); ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ And then some errors caused by unitialized `button'. This can be fixed by installing granite-bzr, so it’s probably a nice idea to change the dependency on granite to the bzr version.

quequotion commented on 2014-03-25 18:04 (UTC)

Failed again because: Vala version 0.23.2 or greater is required. Needs either vala from "gnome-unstable" or vala-git from AUR

quequotion commented on 2014-03-25 17:51 (UTC)

Failed because: package 'gtk+-3.0>=3.11.6' not found Needs either gtk3 from "gnome-unstable" or gtk3-git from AUR

alucryd commented on 2014-03-13 08:51 (UTC)

So, to you, fixing an error message, saying you lack a gstreamer plugin, by installing a gstreamer plugin, is random. That's an interesting point of view.

ak5 commented on 2014-03-13 08:48 (UTC)

After installing all gst-plugins-* packages AND rebooting it (randomly?) started working.

ak5 commented on 2014-03-13 08:18 (UTC)

Hi I am getting a dialog with "Required GStreamer plugin not installed", specifically, it wants an "ID3 tag demuxer". Any ideas?

philpirj commented on 2014-01-19 21:00 (UTC)

sqlheavy is now sqlheavy-git

alucryd commented on 2013-12-01 18:20 (UTC)

noise has been ported to GStreamer 1.0

alucryd commented on 2013-11-11 10:22 (UTC)

Springbank: Those files are provided by gst-plugins-base-libs, but created with vala 0.22, I 'm no vala expert but they are probably incompatible with 0.16. Please file a bug report upstream asking for vala 0.22 support. BTW, last time I checked elementaryOS was using totem as their video player, I don't know if audience is still supported.

Springbank commented on 2013-11-11 07:39 (UTC)

Hi, Install failed again :( Pastebin:http://pastebin.archlinux.fr/474993 Thx for your help

alucryd commented on 2013-11-07 13:11 (UTC)

Thats because you typed vala-0.16 instead of valac-0.16.

Springbank commented on 2013-11-07 12:30 (UTC)

Hi, Thanks for your answer, install failed too. The pastebin: http://pastebin.archlinux.fr/473691

alucryd commented on 2013-11-05 22:17 (UTC)

Springbank: Can you try installing vala0.16 and adding "-DVALA_EXECUTABLE='/usr/bin/valac-0.16'" to the cmake line? That's probably a vala issue, but I can't be sure. Either way, you should open a bug report on launchpad so audience devs can have a look at it. BTW yaourt is bad for your health :P

Springbank commented on 2013-11-05 21:50 (UTC)

hi, i can't update audience-bzr, you can see the pastebin here: http://pastebin.archlinux.fr/473635

alucryd commented on 2013-06-05 15:37 (UTC)

silenc3r: Please file a bug report upstream then, I can't help much since the log isn't very informative and it's working fine here.

silenc3r commented on 2013-06-05 15:12 (UTC)

Didn't help. Not much luck with elementary-icons-{,.bzr} either.

alucryd commented on 2013-06-05 14:37 (UTC)

silenc3r: No issue whatsoever here, using the Faience icon set too. Try to reinstall faience-icon-theme.

silenc3r commented on 2013-06-05 14:16 (UTC)

terminal output once again, this time in English: http://pastebin.com/qLGqxMaS

silenc3r commented on 2013-06-05 13:56 (UTC)

Hey, I'm having problem with icons: http://postimg.org/image/w3p4hvs3x/ Here's output I'm getting while launched from terminal: http://pastebin.com/qX5WPKG8

alucryd commented on 2012-11-21 17:48 (UTC)

@hachel: use the package I just uploaded instead: 'clutter-gst1.6'. audience builds fine but I get a segfault when attempting to run it.

commented on 2012-11-16 19:22 (UTC)

Now it works! Thanks Ner0 :)

Ner0 commented on 2012-11-16 08:43 (UTC)

Try it now.

commented on 2012-11-16 08:34 (UTC)

I can't install it: ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ Linking C executable noise /usr/bin/ld: CMakeFiles/noise.dir/Views/GridView/GridLayout.c.o: undefined reference to symbol 'roundf@@GLIBC_2.1' /usr/bin/ld: note: 'roundf@@GLIBC_2.1' is defined in DSO /usr/lib/libm.so.6 so try adding it to the linker command line /usr/lib/libm.so.6: could not read symbols: Invalid operation collect2: error: ld devolvió el estado de salida 1 make[2]: *** [src/noise] Error 1 make[1]: *** [src/CMakeFiles/noise.dir/all] Error 2 make: *** [all] Error 2 ==> ERROR: Se produjo un error en build(). Cancelando... ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ What can i do?

commented on 2012-11-07 17:40 (UTC)

cmake fails because of missing clutter-gst-1.0

commented on 2012-09-30 21:57 (UTC)

I don't have that tab :(

Ner0 commented on 2012-09-30 05:15 (UTC)

They are already added (json-glib, libxml, libsoup). Go to Preferences - Last.fm and click "Give Noise Permission".

commented on 2012-09-29 07:11 (UTC)

What is the dependency of the last.fm module? How can i add it?

archer commented on 2012-08-27 00:04 (UTC)

bzr 949: /aur-noise-bzr/src/noise-build/src/Widgets/SidebarPaned.vala:23.1-23.72: error: `Granite.Widgets' already contains a definition for `SidebarPaned' public class Granite.Widgets.SidebarPaned : Gtk.EventBox, Gtk.Orientable { ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ granite.vapi:452.3-452.58: note: previous definition of `SidebarPaned' was here public class SidebarPaned : Gtk.EventBox, Gtk.Orientable { ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ Compilation failed: 1 error(s), 0 warning(s) make[2]: *** [src/config.c] 错误 1 make[1]: *** [src/CMakeFiles/noise.dir/all] 错误 2 make: *** [all] 错误 2

Ner0 commented on 2012-08-15 15:49 (UTC)

Install gstreamer0.10-plugins, i think that should solve the problem.

archer commented on 2012-08-15 13:24 (UTC)

@NerO All plugins! All of theme can't work,LastFM mprics .Seems no load any plugins.

Ner0 commented on 2012-08-15 13:18 (UTC)

Added libdbusmenu and libindicate deps. If you have a problem with building libindicate, add '!makeflags' to the options in its PKGBUILD @archer What plugins? Do you mean LastFM?

archer commented on 2012-08-15 07:42 (UTC)

plugins can't work! Download DEB package from PPA can't work too~

commented on 2012-08-15 07:03 (UTC)

Please add libdbusmenu and libindicate to the dependencies. Thank you.

commented on 2012-06-13 16:45 (UTC)

Appears to be a known bug https://bugs.launchpad.net/noise/+bug/1006465

0rAX0 commented on 2012-06-08 17:03 (UTC)

Same issue as MrBIMC. :/

commented on 2012-06-04 12:08 (UTC)

Guys, i've built it normally(without critical errors, yaourt said everything should work), but still noise wont launch: [FATAL 15:05:46.757689] beat_box_media_get_isTemporary: assertion `self != NULL' failed [FATAL 15:05:46.757915] Noise will not function properly. [INFO 15:05:47.084940] [LibraryWindow:1051] clearing all views... [INFO 15:05:47.085306] [LibraryWindow:1061] all cleared [WARN 15:05:47.088771] [GLib-GObject] invalid (NULL) pointer instance [FATAL 15:05:47.088879] [GLib-GObject] g_signal_emit_by_name: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed [FATAL 15:05:47.088938] Noise will not function properly. Ошибка сегментирования(Error of segmenting) So, how to fix it?

Unia commented on 2012-04-23 18:08 (UTC)

Nevermind, I was using regular granite instead of granite-bzr. Misinterpret your message! Thanks for the quick replies and help!

Unia commented on 2012-04-23 17:56 (UTC)

I was using vala-devel because I was using the old PKGBUILD. Now however with vala (0.16.0-1) I am getting the same error.

Ner0 commented on 2012-04-23 17:41 (UTC)

Are you using the stable versions of glib2 (2.32.1-2) and vala (0.16.0-1)?

Unia commented on 2012-04-23 15:59 (UTC)

Oke, now granite builds. Getting an error with noise-bzr now though: /home/jente/abs/aur/noise-bzr/src/noise-build/src/LibraryWindow.vala:456.4-456.23: warning: GLib.Thread.create has been deprecated since 2.32. Use new Thread<T> () Compilation failed: 4 error(s), 42 warning(s) make[2]: *** [src/config.vapi] Fout 1 make[1]: *** [src/CMakeFiles/noise.dir/all] Fout 2 make: *** [all] Fout 2 ==> ERROR: A failure oc

Ner0 commented on 2012-04-23 14:51 (UTC)

What about now? GTK3.4 is in [extra]. Btw. now yo can use regular granite-bzr package. I can build it fine.

Unia commented on 2012-04-22 16:28 (UTC)

Perhaps cause I have GTK3.4? Sorry for spamming!

Unia commented on 2012-04-22 16:27 (UTC)

Nope, wait, same error: /home/jente/abs/aur/granite-bzr/src/granite-build/lib/Widgets/widgets-utils.c: In functie ‘granite_widgets_show_about_dialog’: /home/jente/abs/aur/granite-bzr/src/granite-build/lib/Widgets/widgets-utils.c:70:16: let op: assignment makes pointer from integer without a cast [enabled by default] make[2]: *** [lib/CMakeFiles/granite.dir/Widgets/widgets-utils.c.o] Fout 1 make[1]: *** [lib/CMakeFiles/granite.dir/all] Fout 2 make: *** [all] Fout 2 ==> ERROR: A failure occurred in build(). Aborting... Any fix? note this happens in granite-bzr, so not noise-bzr

Unia commented on 2012-04-22 16:26 (UTC)

Thanks, I was just strugling with that!