Package Details: qt4 4.8.7-31

Git Clone URL: https://aur.archlinux.org/qt4.git (read-only)
Package Base: qt4
Description: A cross-platform application and UI framework
Upstream URL: https://www.qt.io
Licenses: custom, GPL3, LGPL, FDL
Conflicts: qt
Replaces: qt<=4.8.4
Submitter: arojas
Maintainer: dviktor
Last Packager: dviktor
Votes: 28
Popularity: 3.44
First Submitted: 2019-05-01 11:51
Last Updated: 2019-07-29 18:11

Dependencies (29)

Required by (676)

Sources (20)

Pinned Comments

dviktor commented on 2019-06-18 12:50

Binary version for latest version (4.8.7-31) with PGP signature is available here

eschwartz commented on 2019-05-09 13:24

@semeion,

qt4 was expelled from the official repositories due to https://lists.archlinux.org/pipermail/arch-dev-public/2019-April/029560.html

It will not be restored, because software needs to stop using qt4. It's fine for people to still use it via the AUR if they have old software that is not ported, but the proper solution is to get that software ported to qt5.

"It takes a long time to compile" is not a reason to move it to community.

@xuanruiqi,

Only Developers and Trusted Users have access to pkgbuild.com, and we will not be uploading qt4 there. If we wanted qt4, we would upload it to community, but we don't -- we have managed to move every package still being actively maintained in the official repos, over to qt5, and we want to stay that way.

...

Again, the proper long-term solution is to get software ported over to qt5.

dviktor commented on 2019-05-05 17:49

For those who have problems with ‘std::tr1’ has not been declared error: build in clean chroot with extra-x86_64-build script.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

eschwartz commented on 2019-05-10 14:52

Except none of that makes sense. sip does not need qt4, and it doesn't need qt5 either -- it just generates code for them. And the real issue with sip is that in the latest version of sip, the upstream developer of sip, removed all qt4 support. https://www.riverbankcomputing.com/hg/sip/rev/328f2e872d64

All three of those packages are AUR packages... it's not unheard of for one AUR package to depend on another. And spflashtool-bin requires qtwebkit in addition to qt4... do you realize qtwebkit has been in the AUR for two years now?

This is not about "drying the well", and we're not trying to force anyone to port anything. We're simply saying that for years we've only begrudgingly supported qt4 at all, and we finally decided to stop. There's no use getting upset about the lack of support for really old things; we don't support KDE3, gnome2, linux 3.x either, now it is qt4's turn.

My advice is to port it or ask someone else to port it, because getting it ported will make it easier to run without requiring AUR packages, and will be beneficial in the long run either way.

Alternatively, look for modern alternatives to these packages.

dviktor commented on 2019-05-10 14:34

@Tharbad recheck your /etc/makepkg.conf and also show us steps how do you create clean chroot. Please post full relevant error so we can inspect it.

@piedro I think it's clear now how to build this package. For those who can't build it under usual environment method with clean chroot exists and works just fine.

It's inevitable that some software becomes obsolete and out-of-date, new versions will replace the old one - this is normal process of software development. Great example are GCC compilers version 6 and 7 (and, in near future, 8) - they are also moved out to the AUR and also requires a lot of time to build but I don't see anyone who complains about it. If you're not satisfied with AUR solution you can always find binary repository for qt4 and install it directly.

mozo commented on 2019-05-10 12:50

@piedro +1

piedro commented on 2019-05-10 11:54

The package "sip" is in the official extra repository and still needs qt4.

Also "everpad", "soundwire", "spflashtool"... to name only a few.

The idea to "dry the well" to make people behave in a certain way seems very questionable to me... The decision to make it harder for users in order to force porting is really twisted! And also misdirected. The result is that the users waste their time on figuring out how to compile qt4 while the developers of the "old" applications just don't care...

But well, though I am not a developer responsible for porting to qt5 I still need qt4 - so I will have to figure out how to compile it. What a waste of time.

pk

Tharbad commented on 2019-05-10 03:24

Getting ‘std::tr1’ has not been declared despite building in clean chroot

dviktor commented on 2019-05-09 23:53

@deemoncheeque did you download the whole snapshot or just PKGBUILD?

deemoncheeque commented on 2019-05-09 18:01

I'm building the package in clean chroot and it fails with one or more PCH files were found, but they were invalid. What to do with it now? Bin: https://pastebin.com/iNzDFYxq

eschwartz commented on 2019-05-09 13:24

@semeion,

qt4 was expelled from the official repositories due to https://lists.archlinux.org/pipermail/arch-dev-public/2019-April/029560.html

It will not be restored, because software needs to stop using qt4. It's fine for people to still use it via the AUR if they have old software that is not ported, but the proper solution is to get that software ported to qt5.

"It takes a long time to compile" is not a reason to move it to community.

@xuanruiqi,

Only Developers and Trusted Users have access to pkgbuild.com, and we will not be uploading qt4 there. If we wanted qt4, we would upload it to community, but we don't -- we have managed to move every package still being actively maintained in the official repos, over to qt5, and we want to stay that way.

...

Again, the proper long-term solution is to get software ported over to qt5.

semeion commented on 2019-05-08 20:02

@piedro, I really think qt4 should be moved to mainline repo ... a lot of work to compile something used by multiple applications that are in the mainline repo.

piedro commented on 2019-05-08 17:49

Is this becessary in any way? I mean, is there a problem using the older version?

This compiling doesn't work and setting up another environment just to compile it seems a bit over the top imho...

Also, is there a binary to use somewhere?

thx, p.