Package Details: qt4 4.8.7-31

Git Clone URL: https://aur.archlinux.org/qt4.git (read-only)
Package Base: qt4
Description: A cross-platform application and UI framework
Upstream URL: https://www.qt.io
Licenses: custom, GPL3, LGPL, FDL
Conflicts: qt
Replaces: qt<=4.8.4
Submitter: arojas
Maintainer: dviktor
Last Packager: dviktor
Votes: 28
Popularity: 3.55
First Submitted: 2019-05-01 11:51
Last Updated: 2019-07-29 18:11

Dependencies (29)

Required by (676)

Sources (20)

Pinned Comments

dviktor commented on 2019-06-18 12:50

Binary version for latest version (4.8.7-31) with PGP signature is available here

eschwartz commented on 2019-05-09 13:24

@semeion,

qt4 was expelled from the official repositories due to https://lists.archlinux.org/pipermail/arch-dev-public/2019-April/029560.html

It will not be restored, because software needs to stop using qt4. It's fine for people to still use it via the AUR if they have old software that is not ported, but the proper solution is to get that software ported to qt5.

"It takes a long time to compile" is not a reason to move it to community.

@xuanruiqi,

Only Developers and Trusted Users have access to pkgbuild.com, and we will not be uploading qt4 there. If we wanted qt4, we would upload it to community, but we don't -- we have managed to move every package still being actively maintained in the official repos, over to qt5, and we want to stay that way.

...

Again, the proper long-term solution is to get software ported over to qt5.

dviktor commented on 2019-05-05 17:49

For those who have problems with ‘std::tr1’ has not been declared error: build in clean chroot with extra-x86_64-build script.

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 Next › Last »

dviktor commented on 2019-05-04 23:11

Started topic https://bbs.archlinux.org/viewtopic.php?pid=1844520

mozo commented on 2019-05-04 21:42

@dviktor yes I know and that is the reason I posted it separately. But different or not, I can't install the qt4 package :)

dviktor commented on 2019-05-04 21:20

@mozo your error with makepkg differs from error caused by AUR managers.

@FMB could you please post a topic on forum to help fixing it? I can't reproduce this on two different machines and I don't know why. This package was pushed to AUR several days ago from official repos. The only change made by me is patching asm volatile issue

mozo commented on 2019-05-04 21:09

It doesn't build for me:

https://pastebin.com/KYWtbKEd

I tried with trizen, yaourt, yay and makepkg to no avail.

With makepkg the error is the following:

https://pastebin.com/e3rm6v4d

FMB commented on 2019-05-04 20:47

Same error with makepkg :-(

dviktor commented on 2019-05-04 19:53

Seems like some AUR managers can't handle echo lines in PKGBUILD properly... Very strange

RusWolf commented on 2019-05-04 19:42

Through yay, the package is going fine.

twisted-space commented on 2019-05-04 18:37

@dviktor

I usually use pacmac but I can use makepkg and did so for the last couple of tests. Happy to try whatever is needed but I'm about to go out for the evening, so will post any results tomorrow.

dviktor commented on 2019-05-04 18:06

I just noticed that PKGBUILD already contains lines with -std=gnu++98. It should place them where appropriate. How do you install package? Could you try simple makepkg (that works for me)?

EDIT: yay builds and install package fine too. Tested on another machine

alfredo.ardito commented on 2019-05-04 17:55

Same problem as others. gcc version 8.3.0, default makepkg.conf