Package Details: unreal-engine 4.25.4-3

Git Clone URL: https://aur.archlinux.org/unreal-engine.git (read-only, click to copy)
Package Base: unreal-engine
Description: A 3D game engine by Epic Games which can be used non-commercially for free.
Upstream URL: https://www.unrealengine.com/
Keywords: 3D engine game UE4 Unreal
Licenses: custom:UnrealEngine
Submitter: acerix
Maintainer: acerix (zerophase, Shatur)
Last Packager: Shatur
Votes: 57
Popularity: 0.96
First Submitted: 2016-05-01 18:37
Last Updated: 2020-11-21 02:34

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

eyupgurel commented on 2019-12-05 18:15

Do not install 4.23.1 UE4Editor freezes intermittently. Impossible to use in production.

acerix commented on 2019-12-03 22:39

@niqingliang2003 Thanks and nice work, I was able to compile and added your patches.

I don't know of a way to skip stripping on some files. I think those binaries are used in cross-compilation, when I tried to delete them before it made the editor crash.

@tomsk I also get that error, but I'm not sure if they dropped support for cards without Vulkan or if we could add a patch for opengl support.

niqingliang2003 commented on 2019-12-02 06:49

can we skip to strip the mac/windows binaries? or even don't install mac/windows binaries?

tomsk commented on 2019-12-01 15:47

Does anybody have this problem? https://answers.unrealengine.com/questions/937507/cannot-start-unreal-engine-4-in-linux.html

niqingliang2003 commented on 2019-12-01 04:33

  1. the ue4editor will freeze every 3 seconds. https://forums.unrealengine.com/development-discussion/engine-source-github/1617597-ue4editor-constantly-crashes-and-freezes-using-linux

  2. the project packaged can't start for vulkan initialize failed.

niqingliang2003 commented on 2019-11-30 13:45

@acerix Hello, I have added two patches for it: please see https://github.com/walkthetalk/aurpackages/tree/master/unreal-engine

fix_dependency.patch: fix for UE4Editor link error - undefined reference FEditorStyle::Instance (libSourceControl.so need it)

remove_sysctl_include.patch: remove sysctl.h which is deprecated in glibc, I removed it simply, (it looks like is needed on other system, e.g. BSD)

acerix commented on 2019-11-27 03:15

I added a patch to allow Clang 9 because it specifically prevents compiling with Clang > 8. Compilation seemed to be going ok, but finally ended with this unhelpful error:

[2081/2083] Link (ld) libUE4Editor-Advertising.so
[2082/2083] Copy AgentInterface.dll
make: *** [Makefile:588: UE4Editor] Error 5
==> ERROR: A failure occurred in build().

Might be hard to get it to build with Clang 9 until Epic adds support.

tomsk commented on 2019-11-19 21:29

@zerophase when will be Clang 9 fixed?

zerophase commented on 2019-10-15 20:26

@pr0me7heu2 you can undo the patches for using the system compiler, or fix the errors from clang 9. I'll be doing the latter over the next few days.

pr0me7heu2 commented on 2019-10-15 01:12

This looks to not be compatible with Clang 9 as I got this error today:


Building UnrealVersionSelector... ves_icall_TypeBuilder_create_runtime_class_raw USED 132 handles

Using 'git status' to determine working set for adaptive non-unity build (/home/$USER/.cache/yay/unreal-engine/src/UnrealEngine). Creating makefile for UnrealVersionSelector (no existing makefile) ERROR: This version of the Unreal Engine can only be compiled with clang 8.0, 7.0 and 6.0. clang 9.0.0 may not build it - please use a different version. make: *** [Makefile:5: UnrealVersionSelector-Linux-Shipping] Error 5 ==> ERROR: A failure occurred in prepare(). Aborting... Error making: unreal-engine


Is there a work around that I am missing in the comments?