Package Details: viber 13.3.1.22-1

Git Clone URL: https://aur.archlinux.org/viber.git (read-only, click to copy)
Package Base: viber
Description: Proprietary cross-platform IM and VoIP software
Upstream URL: https://www.viber.com
Licenses: custom
Submitter: MohammadR
Maintainer: nslxndr
Last Packager: nslxndr
Votes: 252
Popularity: 2.21
First Submitted: 2013-08-20 17:20
Last Updated: 2020-08-15 20:42

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

dpp commented on 2020-04-17 16:18

I have the same issue like rapurapu - calls don't work anymore

vs220 commented on 2020-04-11 09:48

@ssk This has affected many programs

Comment by grayarcher (grayarcher) - Saturday, 21 March 2020, 17:44 GMT+2 "The root cause here is a change in glibc, as noted by the 2.31 release notes:

  • System call wrappers for time system calls now use the new time64 system calls when available. On 32-bit targets, these wrappers attempt to call the new system calls first and fall back to the older 32-bit time system calls if they are not present. This may cause issues in environments that cannot handle unsupported system calls gracefully by returning -ENOSYS. Seccomp sandboxes are affected by this issue.

Since it's the individual applications like Discord, or any other electron/CEF based/like app that apply the seccomp filter, they will have to adjust their filters. Until that happens, the options are: - Patch the individual binaries to allow clock_gettime64, similary to how the source code changed in upstream chromium for a previous issue: https://github.com/chromium/chromium/commit/54407b422a9cbf775a68c1d57603c0ecac8ce0d7#diff-76dd4327967fba9837d93a944eeb1165

(A similar change was commited to OpenSSH https://github.com/openssh/openssh-portable/commit/ccd3b247d59d3bde16c3bef0ea888213fbd6da86#diff-5039537cc0e0b50db6f66642be1248fa ) - Downgrade glibc/revert that specific change in glibc"

ssk commented on 2020-04-10 03:49

After update error is shown:
qrc:/QML/DebugMenu.qml:262: TypeError: Cannot call method 'isWasabiEnabled' of undefined qrc:/QML/DebugMenu.qml:289: TypeError: Cannot call method 'isSearchInCommunitiesForceEnabled' of undefined qrc:/QML/DebugMenu.qml:296: TypeError: Cannot call method 'isOOABURISpamCheckerForceEnabled' of undefined qrc:/QML/DebugMenu.qml:304: TypeError: Cannot call method 'isRateCallQualityForceEnabled' of undefined [1:14:0410/092611.970084:ERROR:adm_helpers.cc(73)] Failed to query stereo recording. ../../3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:CRASHING:seccomp-bpf failure in syscall 0230

rapurapu commented on 2020-04-08 13:18

Call is not working somehow.

vs220 commented on 2020-03-25 18:03

@nik123true It works without qt5-base

Check out

LD_LIBRARY_PATH=/opt/viber/lib /usr/bin/viber

LD_LIBRARY_PATH=/opt/viber/lib ldd /usr/bin/viber |grep Qt5 ??

nik123true commented on 2020-03-25 17:03

Please include qt5-base as a dependency because viber doesn't work without it.

hubcap commented on 2020-01-05 15:10

Symlink /usr/bin/viber starting with lowercase letter. This causes firejail profile https://github.com/netblue30/firejail/blob/master/etc/Viber.profile to fail. Minor inconvenience, not sure if should be fixed.

nslxndr commented on 2019-12-07 13:52

I updated the package, sorry for the delay. @vyachkonovalov I applied the most of your changes, thanks for your work.

crabvk commented on 2019-12-03 10:06

Oops, I made a mistake and removed PKGBUILD before making a git diff :D
Here is my patch, without unnecessary eula.html and viber (shell script) files, proper LICENSE, also fixed sed replacement for viber.desktop.
https://gist.github.com/vyachkonovalov/81a9ad265f437f9f40f7a3393aefc65b

iraklisg commented on 2019-12-02 18:13

@bbolgradov I manually added a new line at the end of your downloaded patch and I was able to successfully proceed with viber installation. Thank you