Package Details: viber 13.3.1.22-1

Git Clone URL: https://aur.archlinux.org/viber.git (read-only, click to copy)
Package Base: viber
Description: Proprietary cross-platform IM and VoIP software
Upstream URL: https://www.viber.com
Licenses: custom
Submitter: MohammadR
Maintainer: nslxndr
Last Packager: nslxndr
Votes: 252
Popularity: 2.21
First Submitted: 2013-08-20 17:20
Last Updated: 2020-08-15 20:42

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

bbolgradov commented on 2019-12-02 18:02

Should be fixed now. Github gists seem to get their last newline stripped.

Hubro commented on 2019-12-02 17:40

@iraklisg Same for me. Just use bbolgradov's patch as a reference and update the version and hash manually, worked nicely for me :)

iraklisg commented on 2019-12-02 17:39

@bbolgradov @vyachkonovalov Thank you for your reply.

Interestingly, running git apply viber-12.0.0.7-1.patch gives me the following error:

error: corrupt patch at line 2

The same applies to vyachkonovalov's solution were I get:

error: corrupt patch at line 176

Am I missing something? Can I provide you some extra information?

bbolgradov commented on 2019-12-02 15:00

@vyachkonovalov, that's a strange patch you've got there.

Here's a working one that simply bumps the version.

yay -G viber
cd viber
wget https://gist.githubusercontent.com/bbolgradov/0f34f525d001746e6addf8e790633563/raw/8448bc7ad3ec68a38f9b7694d7e2f6b73af5fcc5/viber-12.0.0.7-1.patch
git apply viber-12.0.0.7-1.patch
makepkg -sci

crabvk commented on 2019-12-01 16:53

Wow, this version is so outdated.

@iraklisg Current is 12.0.0.7, here is the patch

How to apply the patch:

yay -G viber # not sure about this one, I don't use yay
cd viber
curl -O 'https://gist.githubusercontent.com/vyachkonovalov/c82390fb3d2fda95be89c8d21f657a26/raw/53f1ba9c4f44e2feae20155f506fdf5b6988f9a3/PKGBUILD.diff'
git apply PKGBUILD.diff
makepkg -si

iraklisg commented on 2019-11-30 17:15

Installing via yay:

Validating source files with md5sums...
    viber-10.3.0.37.tar.gz ... FAILED
    eula.html ... Passed
    viber ... Passed
==> ERROR: One or more files did not pass the validity check!
Error downloading sources: viber

Choosing the package to be Clean builded did not do the trick for me:

al3xxx commented on 2019-11-06 15:58

Hello,

Please remove libcurl-compat from dependencies, Viber works OK without it, but presence libcurl-compat in the system breaks a lot of AUR packages with following configure errors:

configure:8766: gcc -o conftest -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now conftest.c -lalpm   >&5
/usr/bin/ld: /usr/lib/libcurl.so.4: undefined reference to `OpenSSL_version_num@OPENSSL_1_1_0'
/usr/bin/ld: /usr/lib/libssh2.so.1: undefined reference to `EVP_des_ede3_cbc@OPENSSL_1_1_0'
/usr/bin/ld: /usr/lib/libcurl.so.4: undefined reference to `SSL_CTX_set_srp_password@OPENSSL_1_1_0'
/usr/bin/ld: /usr/lib/libssh2.so.1: undefined reference to `EC_KEY_get0_group@OPENSSL_1_1_0'
/usr/bin/ld: /usr/lib/libarchive.so.13: undefined reference to `EVP_aes_128_ecb@OPENSSL_1_1_0'
/usr/bin/ld: /usr/lib/libcurl.so.4: undefined reference to `SSL_CTX_use_certificate_chain_file@OPENSSL_1_1_0'

crabvk commented on 2019-09-24 16:59

Hello. Please change source to https.

antonjo commented on 2019-09-03 14:26

I get the following CLI error:

~ >>> viber                                                                                                                                                   
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method

zfkerr commented on 2019-07-11 19:52

Hi, @nslxndr ! Please, add the "openssl-1.0" package to the dependencies section. Viber don't want to work without it.