Package Details: xfconf-git 4.16.0+102+gb836868-1

Git Clone URL: (read-only, click to copy)
Package Base: xfconf-git
Description: A simple client-server configuration storage and query system - git checkout
Upstream URL:
Licenses: GPL2
Groups: xfce4
Conflicts: terminal, xfconf
Provides: xfconf
Replaces: terminal, xfconf
Submitter: killermoehre
Maintainer: killermoehre
Last Packager: killermoehre
Votes: 2
Popularity: 0.000000
First Submitted: 2018-07-22 14:23 (UTC)
Last Updated: 2022-03-26 19:38 (UTC)

Required by (47)

Sources (1)

Latest Comments

Kunda commented on 2023-07-06 13:11 (UTC) (edited on 2023-07-06 13:12 (UTC) by Kunda)

@killermoehre do you mind appending 's' to the http:// 'Upstream URL:' (ie field of this package. Trying to resolve warnings in

mirh commented on 2020-01-10 16:08 (UTC)

As reported in the comments of libxfce4ui, could you update the pkgver parsing? It's breaking dependency recognition

git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^[^[:digit:]]*//;s/-/+/g"

IOAOI commented on 2019-10-08 14:01 (UTC)

The version error is already noted on libxfce4ui-git, but seems to be a problem here too. yay said: :: 2 Packages to upgrade. 2 aur/libxfce4ui-git 1:xfce+4.14.0+10+g8334ce9-1 -> 1:4.13.4+26+gfab274c-1 1 aur/xfconf-git xfce.4.14.0.r3.ga92edcc-1 -> 4.13.5.r54.gd2b8a3e-1

warning: xfconf-git-xfce.4.14.0.r3.ga92edcc-1 is up to date -- reinstalling warning: libxfce4ui-git-1:xfce+4.14.0+10+g8334ce9-1 is up to date -- reinstalling

But also, if I install other xfce4 -git packages that depend on these it does not seem to provide the right thing, so I have to remove them:

looking for conflicting packages... :: libxfce4ui and libxfce4ui-git are in conflict. Remove libxfce4ui-git? [y/N] y :: xfconf and xfconf-git are in conflict. Remove xfconf-git? [y/N] y

killermoehre commented on 2019-03-10 17:36 (UTC)

@danboid done

danboid commented on 2019-03-09 21:29 (UTC)

The dependencies of the official xfconf PKGBUILD are:

depends=('libxfce4util' 'dbus-glib') makedepends=('perl-extutils-depends' 'perl-extutils-pkgconfig' 'glib-perl' 'intltool' 'chrpath')

So I think this package should use the same. I forgot to mention chrpath in my previous post. That is definitely needed to build and not necessarily installed.

danboid commented on 2019-03-09 12:08 (UTC)

The xfconf-git PKGBUILD is currently missing a few (build) dependencies to get a fully working XFCE desktop, namely:

glib-perl perl-extutils-depends perl-extutils-pkgconfig

xfconf builds without these installed but I found that not having these packages installed before building xfconf breaks xfce4-display-settings ability to control displays.