Package Details: vala-panel-appmenu-xfce-git 24.02.r1.gced6ce3-1

Git Clone URL: https://aur.archlinux.org/vala-panel-appmenu-xfce-git.git (read-only, click to copy)
Package Base: vala-panel-appmenu-xfce-git
Description: AppMenu (Global Menu) plugin for xfce4-panel
Upstream URL: https://gitlab.com/vala-panel-project/vala-panel-appmenu
Licenses: LGPL3
Conflicts: vala-panel-appmenu-xfce
Provides: vala-panel-appmenu-xfce
Submitter: rilian
Maintainer: rilian
Last Packager: rilian
Votes: 37
Popularity: 0.192520
First Submitted: 2015-04-01 21:00 (UTC)
Last Updated: 2024-05-07 14:12 (UTC)

Required by (5)

Sources (1)

Latest Comments

1 2 3 4 5 6 .. 25 Next › Last »

rilian commented on 2024-05-26 14:06 (UTC)

It is not tightly coupled. If you will install vala-panel 24.05, it should work with stable ones. If something do not build - please, post your log into git package comments.

xiota commented on 2024-05-26 10:17 (UTC)

vala-panel-git, vala-panel-appmenu-*-git, and associated -git packages appear to be tightly coupled and incompatible with the stable, non-git, versions. Recommend strict conflicts (no provides) and explicit depends on the -git variants.

The stable packages have been updated to prevent cross-installations, but it may not be fully effective without similar changes in the git packages.

rilian commented on 2024-05-07 14:13 (UTC) (edited on 2024-05-07 14:14 (UTC) by rilian)

@xiota

It has, in separate vala-panel section. Just updated required version to 24.05 just in case if your tools will compile it properly.

Look here in PKGBUILD:

if (("${_disable_vala}" == 0));then
    _opts+=(-Dvalapanel=enabled)
    pkgname+=('vala-panel-appmenu-valapanel-git')
    makedepends+=('vala-panel>=24.05') #I updated version here
#   msg "Vala Panel applet enabled"
fi

rilian commented on 2024-05-06 10:50 (UTC) (edited on 2024-05-06 10:51 (UTC) by rilian)

@xiota

First issue is fixed by building with a latest vala-panel. But now I have vala-panel>=0.4.50 in makedepends, so, I guess, your clean chroot is chooses non-git vala-panel package, which is now has the bug. AFAIK, bug fixed only in git package.

littlehoopoe commented on 2024-05-05 19:49 (UTC)

Thank you all for the help! I've ditched the chaotic aur and reinstalled everything directly from here. Thanks a lot!

Tio commented on 2024-05-05 13:09 (UTC)

Hey so all works now I have informed the chaotic-aur folks too. This is what did it for me:

Build the vala-panel-git package from AUR https://aur.archlinux.org/packages/vala-panel-git

Only after that rebuild the following packages:

appmenu-glib-translator-git
vala-panel-appmenu-xfce-git
vala-panel-appmenu-registrar-git

All works now and thanks a lot for being so helpful!

rilian commented on 2024-05-05 12:32 (UTC)

Tio, just double-check the following to avoid double menus: 1. Is vala-panel-appmenu-registrar latest, up and running? 2. Is your appmenu-gtk-module gsettings allow menus to hide? 3. Is your appmenu-gtk-module works?

What more errors are you have?