Package Details: brave-git 0.24.1.r236.g7e6875794-1

Git Clone URL: https://aur.archlinux.org/brave-git.git (read-only)
Package Base: brave-git
Description: A web browser that stops ads and trackers by default. Master branch.
Upstream URL: https://www.brave.com/
Keywords: browser muon web
Licenses: BSD, Apache, custom:MPL2, custom:others
Groups: networking
Conflicts: brave
Provides: brave, brave-browser
Submitter: vorbote
Maintainer: timschumi
Last Packager: timschumi
Votes: 22
Popularity: 0.600002
First Submitted: 2016-04-06 13:15
Last Updated: 2018-08-08 15:55

Required by (0)

Sources (3)

Latest Comments

1 2 Next › Last »

droidman commented on 2018-10-26 02:30

@timschumi I tried switching the npm python and a python 2 env with no luck. This hack sets python to be python2 instead of python3, and can build successfully. This could be packaged and set as a make dependency as a last resort hack.

"sudo nano /usr/local/bin/python"

!/bin/bash

exec python2 "$@"

"sudo chmod +x /usr/local/bin/python"

timschumi commented on 2018-10-21 09:59

@tuckerboniface The new location alone won't help much (is there even a reason to use it, as the old repository is still being updated?). Due to changes in Brave's build system for the next-gen version, the PKGBUILD is massively broken by now. I took a look at it and tried to fix a few things, but unfortunately, the Chromium scripts assume that python2 is installed as "python", which isn't the case on Arch. If anyone with enough nodeJS knowledge and enough time on their hands is able to come up with a solution to make nodeJS modify the shebang lines between cloning depot_tools and running them, I'll happily switch this to the next-gen version.

tuckerboniface commented on 2018-10-21 02:18

Please use the new location https://github.com/brave/brave-browser

oberon2007 commented on 2018-05-29 00:25

pkgver is broken. Since the repo doesn't provide proper rel tags you should just use

printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"

current result is 'r9490.971344519'

urldog commented on 2017-12-23 09:37

I get: Error installing brave-git : invalid version string: 0.22.0.^3.0.18419.

Using yay, manjaro.

raobe commented on 2017-11-22 17:51

There needs to be two small changes to the PKGBUILD to get this to compile:

Line 51, change to

cp -a --reflink=auto brave-linux-x64 "$pkgdir/usr/lib/$pkgname"

Line 186, change to

install -Dm0644 res/nightly/app.png "$pkgdir"/usr/share/pixmaps/brave.png

mischka commented on 2017-09-23 18:26

@asynec Should be fixed now, let me know if not!

asynec commented on 2017-09-23 17:45

This package is currently creating duplicate icons inside of Dash to Dock on Gnome. I believe it is an error similar to what Chromium used to experience:

https://github.com/micheleg/dash-to-dock/issues/215

vorbote commented on 2017-02-07 02:01

@gutigen, a VCS package is *never* out-of-date. It may need adjustments sometimesm but that's is not the case today. Please don't set gratitous out-of-date flags to VCS packages and I don't mean just this one.

I encourage you to read the wiki:

https://wiki.archlinux.org/index.php/VCS_package_guidelines

vorbote commented on 2016-04-07 00:00

This package was renamed, please use <https://aur.archlinux.org/packages/brave-git/>.