Package Details: libgweather-git 4.4.0.r8.g57a116bf-1

Git Clone URL: https://aur.archlinux.org/libgweather-git.git (read-only, click to copy)
Package Base: libgweather-git
Description: Location and timezone database and weather-lookup library
Upstream URL: https://gitlab.gnome.org/GNOME/libgweather
Licenses: LGPL
Conflicts: libgweather-4
Provides: libgweather-4, libgweather-4.so
Submitter: ignapk
Maintainer: xiota
Last Packager: xiota
Votes: 1
Popularity: 0.000023
First Submitted: 2021-01-15 01:08 (UTC)
Last Updated: 2023-11-14 22:47 (UTC)

Required by (25)

Sources (1)

Latest Comments

1 2 Next › Last »

MarsSeed commented on 2023-08-01 00:20 (UTC)

It is not required to reach "Required by (0)". :)

As gnome-shell-mobile-git legitimately depends directly on libgweather-git, meaning whatever is the latest upstream development version, which currently provides libgweather-4.so.

xiota commented on 2023-07-31 23:58 (UTC) (edited on 2023-07-31 23:59 (UTC) by xiota)

Switching to a metapackage is harmless and makes cleaning up the AUR easier. So that's what I decided to do. Once the issues with those packages have been resolved, either by update or deletion, this metapackage can be removed.

There's a deletion request against libgweather2. Without this metapackage, the ability to find and track related packages would be lost when libgweather2 is deleted. The list of dependents is slightly different between two packages.

There's no need to notify me of each individual package's progress. No further action on this metapackage is needed until the AUR page states, "Required by (0)".

MarsSeed commented on 2023-07-31 22:19 (UTC)

Just now, gnome-calendar-linuxmint's owner submitted a deletion request for that package.

MarsSeed commented on 2023-07-31 13:24 (UTC) (edited on 2023-07-31 13:24 (UTC) by MarsSeed)

And btw none of the libgweather-3.so based packages are used by any active users, and all are now pending deletion except for gnome-calendar-linuxmint.

MarsSeed commented on 2023-07-31 13:21 (UTC)

It's not the job of this VCS package to track which other packages are defunct due to needing but missing libgweather-3.so.

And anyway, you can get the list of the defunct packages by opening libgweather2's page.

xiota commented on 2023-07-31 07:04 (UTC) (edited on 2023-07-31 07:11 (UTC) by xiota)

This is now a split package:

  • libgweather-git is a metapackage to track packages that need to be updated or dropped from AUR.
  • libgweather-4-git is the proper package.

MarsSeed commented on 2023-07-14 08:28 (UTC) (edited on 2023-07-14 08:29 (UTC) by MarsSeed)

I have verified that none of the current dependents of libgweather actually need the v4 of it, except gnome-settings-daemon-ubuntu. But that should have switched over to libgweather-4.

All those packages calling for libgweather are unmaintained and unused - no one complained anywhere about them being broken.

Apart from the above-mentioned ubuntu package, all others explicitly call for libgweather-3.so.

Please remove the now obviously wrong provides and conflicts for libgweather.

(If someone would create a libgweather package for libgweather-3.so, it should be able to coexist with this package, as this only has libgweather-4.so and not the v3 file.)

MarsSeed commented on 2023-07-05 17:33 (UTC)

Hi,

In my observation, this package should no longer provide libgweather, which has meant libgweather-3.so since 2011 until Oct 2022, at which point the package named 'libgweather' was dropped from repo.

But on the other hand, this package should provide libgweather-4.so, like the repo package does.