Package Details: neovim-git 0.4.0.r2116.geee0668818-1

Git Clone URL: https://aur.archlinux.org/neovim-git.git (read-only, click to copy)
Package Base: neovim-git
Description: Fork of Vim aiming to improve user experience, plugins, and GUIs.
Upstream URL: https://neovim.io
Keywords: editor vim
Licenses: custom:neovim
Conflicts: neovim
Provides: neovim=0.4.0.r2116.geee0668818
Submitter: fhahn
Maintainer: fwalch
Last Packager: fwalch
Votes: 207
Popularity: 1.67
First Submitted: 2014-02-21 19:50
Last Updated: 2020-11-03 17:55

Dependencies (20)

Required by (98)

Sources (1)

Pinned Comments

fwalch commented on 2016-07-04 19:52

Please don't flag this package out-of-date just because the version number displayed on AUR seems old. This is normal for VCS packages. As long as building the package works without problems, it isn't necessary to update the PKGBUILD here. makepkg will automatically retrieve the latest version when you build the package locally.

niskii commented on 2014-04-15 10:17

It seems msgpack is another dependency needed to build neovim: http://pastebin.com/hdLbMd4w

cryptix commented on 2014-04-13 09:47

deleted my last comments as they were wrong (the pkgs i listed should be build build by the neovims cmake itself)

cryptix commented on 2014-04-12 20:14

There is a upstream issue about the luajit bin (https://github.com/neovim/neovim/issues/518)

cryptix commented on 2014-04-12 20:05

also, luajit and lua51-lpeg (https://aur.archlinux.org/packages/lua51-lpeg/)

but something is off about finding the luajit bin. i did this quick fix:

[cryptix@planc /mnt/builds/neovim:master*] git diff src/CMakeLists.txt
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8e38839..4d03299 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -3,7 +3,7 @@ include(CheckLibraryExists)
if(DEFINED ENV{LUA_BINARY})
set(LUA_BIN $ENV{LUA_BINARY})
else()
- set(LUA_BIN ${DEPS_BIN_DIR}/luajit)
+ set(LUA_BIN /usr/bin/luajit)
endif()

set(GENERATED_DIR ${PROJECT_BINARY_DIR}/src/auto)


after that lua-cmsgpack (https://github.com/antirez/lua-cmsgpack) is missing but i couldn't figure out how to build the lua 5.1 version of it.

cryptix commented on 2014-04-12 19:50

msgpack (https://aur.archlinux.org/packages/msgpack/) needs to be added to the (build?) dependencies

Anonymous comment on 2014-04-09 21:16

@EvertVP I also got the same error the other day. Pretty sure it's because the official libuv package is now at 0.11.23, and neovim's dependency is still tied to 0.11.22 (can see here https://github.com/neovim/neovim/blob/master/third-party/CMakeLists.txt). As @wget said, the issue is upstream, just have to wait until they update the dependency.

wget commented on 2014-04-09 14:23

@EverVP, please report the error upstream. Btw, if you check the build status at https://github.com/neovim/neovim you see that the code doesn't even compile.

Anonymous comment on 2014-04-09 14:16

I'm getting this error during compilation: http://pastebin.com/v1n9jp2w

fhahn commented on 2014-03-22 15:39

Yes, thanks for the hint. I've added luajit as build dependency for now.

mvdnes commented on 2014-03-22 14:28

This package now seems to have a (build?)dependency of luajit