Package Details: thunar-devel 4.17.6-1

Git Clone URL: https://aur.archlinux.org/thunar-devel.git (read-only, click to copy)
Package Base: thunar-devel
Description: File manager for Xfce (development version)
Upstream URL: https://thunar.xfce.org
Licenses: GPL
Groups: xfce4-devel
Conflicts: thunar
Provides: thunar=4.17.6
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 12
Popularity: 0.029394
First Submitted: 2017-11-27 01:40
Last Updated: 2021-09-26 22:20

Dependencies (20)

Required by (32)

Sources (1)

Latest Comments

csts commented on 2021-09-14 18:09

I had the normal thunar installed.
I didn't need any custom PKGBUILD for thunar-devel, upon installing it with pikaur it asked me for the 3 devel packages to be installed -one at a time-, then it was built flawlessly.
exo-devel, libxfce4ui-devel, libxfce4util-devel.

bittin commented on 2021-09-11 13:59

https://pastebin.com/ay2rRbUN Thunar 4.17.5 PKGBUILD

jonathon commented on 2021-07-19 15:18

PKGBUILD might do with a diff:

diff --git a/PKGBUILD b/PKGBUILD
index 058c1ec..086081a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ arch=('i686' 'x86_64' 'armv7h' 'aarch64')
 license=('GPL')
 groups=('xfce4-devel')
 url='https://thunar.xfce.org'
-depends=('desktop-file-utils' 'exo>=4.15.3' 'gtk3' 'hicolor-icon-theme' 'libgudev'
-         'libexif' 'libnotify' 'libpng' 'libxfce4ui>=4.15.3' 'libxfce4util>=4.15.2')
+depends=('desktop-file-utils' 'exo>=4.17.0' 'gtk3' 'hicolor-icon-theme' 'libgudev'
+         'libexif' 'libnotify' 'libpng' 'libxfce4ui>=4.17.0' 'libxfce4util>=4.17.0')
 makedepends=('intltool' 'xfce4-panel' 'gtk-doc' 'gobject-introspection') # 'xfce4-dev-tools')
 optdepends=('gvfs: trash support, mounting with udisks, and remote filesystems'
                'xfce4-panel: trash applet'

as thunar-devel=4.17.4 will complain about exo, libxfce4ui, and libxfce4util:

checking for exo-2 >= 4.17.0... found, but 4.16.2
*** The required package exo-2 was found on your system,
*** but the installed version (4.16.2) is too old.
*** Please upgrade exo-2 to atleast version 4.17.0, or adjust
*** the PKG_CONFIG_PATH environment variable if you installed
*** the new version of the package in a nonstandard prefix so
*** pkg-config is able to find it.
...
checking for libxfce4ui-2 >= 4.17.0... found, but 4.16.0
*** The required package libxfce4ui-2 was found on your system,
*** but the installed version (4.16.0) is too old.
*** Please upgrade libxfce4ui-2 to atleast version 4.17.0, or adjust
*** the PKG_CONFIG_PATH environment variable if you installed
*** the new version of the package in a nonstandard prefix so
*** pkg-config is able to find it.
...
checking for libxfce4util-1.0 >= 4.17.0... found, but 4.16.0
*** The required package libxfce4util-1.0 was found on your system,
*** but the installed version (4.16.0) is too old.
*** Please upgrade libxfce4util-1.0 to atleast version 4.17.0, or adjust
*** the PKG_CONFIG_PATH environment variable if you installed
*** the new version of the package in a nonstandard prefix so
*** pkg-config is able to find it.

bittin commented on 2021-07-18 07:54

Thunar 4.17.4 PKGBUILD: https://pastebin.com/GG1hKRgR

bittin commented on 2021-05-07 15:29

Thunar 4.17.3 PKGBUILD: https://pastebin.com/yeiyYQ9K

jonathon commented on 2020-11-03 19:44

@bittin, it's good form to provide more information than just "it doesn't work". For example, include an error message, or link to a paste showing the full build output.

As it is, the issue is due to a typo in the build() function:

diff --git a/PKGBUILD b/PKGBUILD
index 0fa785f..af53be8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ conflicts=("${_pkgname}")
 source=("https://archive.xfce.org/src/xfce/${_pkgname}/${pkgver%.*}/${_pkgname}-${pkgver}.tar.bz2")
 sha256sums=('f5f90e77cf6bdffe229d9d3a4d46a0e392d3e94b9ee1af7433e6e2fe45e35c5f')

-uild() {
+build() {
     cd "${_pkgname}-${pkgver}"
     ./configure \
         --prefix=/usr \

bittin commented on 2020-11-03 03:30

The latest version can't be installed

optional_install commented on 2019-09-09 00:49

Kind of late to the party, but I just installed this split thunar on Xfce 4.14 and it works. The other package, Thunar extended, wasn't able to download/find the missing dependencies. So I tried this flagged-out-of-date version (why not?) and it works great. Thank you, developers.

graysky commented on 2019-06-01 15:18

Can you add this as a dependency? Without it, I cannot build in a clean-chroot against needed libxfconf-0.so.3 (the arch-build scripts will download the wrong version from [extra]).

depends=(... xfconf>=4.13.7-1")

Thunar: error while loading shared libraries: libxfconf-0.so.2: cannot open shared object file: No such file or directory

Anonymous comment on 2016-05-11 10:46

The thunar.install file can be removed. The functionality it provides (update icon and MIME type cache) is now handled by pacman hooks automatically.