Package Details: libdart 6.13.0-5

Git Clone URL: (read-only, click to copy)
Package Base: libdart
Description: Dynamic Animation and Robotics Toolkit
Upstream URL:
Keywords: dart dartsim physicsengine robotics
Licenses: BSD
Provides: dartsim
Submitter: bchretien
Maintainer: daizhirui (AchmadFathoni)
Last Packager: daizhirui
Votes: 5
Popularity: 0.000000
First Submitted: 2014-06-19 11:19 (UTC)
Last Updated: 2023-10-31 16:03 (UTC)

Pinned Comments

AchmadFathoni commented on 2023-02-14 03:55 (UTC)

Need co-maintainer for faster development response

midgard commented on 2019-03-01 15:25 (UTC)

If you're interested in some of the optional dependencies, they should be installed before building this package. If you install them later, you have to rebuild this package to use them with DART.

Latest Comments

1 2 3 Next › Last »

daizhirui commented on 2023-10-31 16:06 (UTC)

CXXFLAGS is set to CFLAGS as a temporary fix for the issue.

oysstu commented on 2023-10-20 07:14 (UTC) (edited on 2023-10-20 07:16 (UTC) by oysstu)

I've had problems with libdart crashing. I've narrowed it down to improper indexed access of a vector, which is being caught by an assertion because archlinux compiles with D_GLIBCXX_ASSERTIONS by default. My fix so far has been to redefine CXXFLAGS to disable the assertions (export CXXFLAGS="$CFLAGS").

I've reported the issue upstream here:

AchmadFathoni commented on 2023-03-06 02:35 (UTC)

Now you can open PR here

j_klee commented on 2023-03-05 16:09 (UTC)

Maybe you can make a repository at github? Then we can simply ask for a pull request. I also had the following problems stated below:

  1. fmt is a dependency that was missing in my case (from leuko)
  2. I needed to add the option -DDART_TREAT_WARNINGS_AS_ERRORS="off" (form angelodalzotto)

AchmadFathoni commented on 2023-02-14 03:55 (UTC)

Need co-maintainer for faster development response

angelodalzotto commented on 2023-02-13 22:21 (UTC)

I could not build here unless it is added -DDART_TREAT_WARNINGS_AS_ERRORS="off" to cmake line in build()

leuko commented on 2023-02-13 16:01 (UTC)

dep missing: fmt

AchmadFathoni commented on 2021-11-17 09:08 (UTC)

Remove flann dependency

# The latest tag 1.9.1 doesn't support C++17, which is the minimum
# requirement of DART >= 6.12. It should be resolved once
# as mainline already
# has the fix but just not released yet. Until then, the minimum
# required flann version to 1.9.2, which should be correctly updated
# once a new flann release is out.

acxz commented on 2019-05-02 19:17 (UTC)

Maintaining package currently. pagmo is now a dependency.