Package Details: libdart 6.12.1-2

Git Clone URL: https://aur.archlinux.org/libdart.git (read-only, click to copy)
Package Base: libdart
Description: Dynamic Animation and Robotics Toolkit
Upstream URL: https://dartsim.github.io
Keywords: dart dartsim physicsengine robotics
Licenses: BSD
Provides: dartsim
Submitter: bchretien
Maintainer: AchmadFathoni
Last Packager: AchmadFathoni
Votes: 5
Popularity: 0.000141
First Submitted: 2014-06-19 11:19 (UTC)
Last Updated: 2021-11-17 09:03 (UTC)

Pinned Comments

midgard commented on 2019-03-01 15:25 (UTC)

If you're interested in some of the optional dependencies, they should be installed before building this package. If you install them later, you have to rebuild this package to use them with DART.

Latest Comments

AchmadFathoni commented on 2021-11-17 09:08 (UTC)

Remove flann dependency

# The latest tag 1.9.1 doesn't support C++17, which is the minimum
# requirement of DART >= 6.12. It should be resolved once
# https://github.com/flann-lib/flann/issues/476 as mainline already
# has the fix but just not released yet. Until then, the minimum
# required flann version to 1.9.2, which should be correctly updated
# once a new flann release is out.

acxz commented on 2019-05-02 19:17 (UTC)

Maintaining package currently. pagmo is now a dependency.

acxz commented on 2019-04-26 01:29 (UTC) (edited on 2019-05-01 14:34 (UTC) by acxz)

When installing this package, as the build goes through the CMakeLists finding dependent packages, I come across the following line: '-- Looking for pagmo - NOT found, to use dart-optimizer-pagmo, please install pagmo'

Should the dependencies be updated to include the 'pagmo' package as well? https://aur.archlinux.org/packages/pagmo

However, even after installing the above mentioned package, the libdart installation still does not recognize it and throws the same warning line. Maybe there is a problem upstream somewhere?

Edit 2019-05-01: Seems like there was an upstream issue with libdart regarding pagmo compilation that has been resolved. https://github.com/dartsim/dart/issues/1299

The issues for pagmo as a dependency are still not fixed tho.

midgard commented on 2019-03-01 15:25 (UTC)

If you're interested in some of the optional dependencies, they should be installed before building this package. If you install them later, you have to rebuild this package to use them with DART.

midgard commented on 2019-03-01 15:23 (UTC)

I updated to the latest version, fixed the tests and added more optional dependencies.

I also added octomap as a dependency, it's necessary to successfully compile (won't link without it). However the build still says “Octomap 1.9.0 is found, but Octomap 1.9.0 or greater is not supported yet. Please see 'https://github.com/dartsim/dart/issues/1078' for the details”. Tests pass now, but I see that the Voxel test described in that issue is disabled if Octomap isn't found, so I'm not sure if that test ran.

@FlyingJay1: renaming AUR packages is not possible, it would have to be deleted and recreated. I don't think it's worth the hassle.

lasagnaphil commented on 2019-02-20 05:35 (UTC)

It seems like the octomap dependency is missing... And you need to install an older version of it (less than 1.9.0), because of the following issue: https://github.com/dartsim/dart/issues/1078

FlyingJay1 commented on 2018-11-20 04:39 (UTC)

This project is called 'dartsim', not 'libdart'. You may want to rename it.

GPereira commented on 2018-05-27 11:48 (UTC)

For now I've updated the package to 6.5 and disabled checking. Do you have any idea how to fix it?

wdna commented on 2018-05-09 09:37 (UTC)

Btw, for me all the tests are failing, I still have to run manually with --nocheck flag. What is required (and missing?) for the tests?

GPereira commented on 2018-05-09 09:17 (UTC)

I've update it, please check it :)

GPereira commented on 2018-05-09 09:07 (UTC)

Nah, send me via email please :) it's in my profile

GPereira commented on 2018-05-09 09:04 (UTC)

Thanks, post it here please

wdna commented on 2018-05-09 09:04 (UTC)

@GPereira I sent the file to your email on profile.

wdna commented on 2018-05-09 08:57 (UTC) (edited on 2018-05-09 09:11 (UTC) by wdna)

@GPereira well I'm not sure what is exactly the issue with flann, however, it did not build at all, a cmake file error. I managed to fix that the following way:

prepare() {
  ..
  touch src/cpp/empty.cpp
  sed -i -e 's/flann_cpp SHARED \"\"/flann_cpp SHARED \"empty\.cpp\"/g' src/cpp/CMakeLists.txt
  sed -i -e 's/flann SHARED \"\"/flann SHARED \"empty\.cpp\"/g' src/cpp/CMakeLists.txt
}

then I also removed the lz4 patch from flann and walla, libdart-6.4.0 was built:

Packages (1) libdart-6.4.0-1

I have updated PKGBUILD for flann, how can I send you?

GPereira commented on 2018-05-09 07:58 (UTC)

I do not own flann but I comantain it, send me the PKGBUILD for it and I upload it :)

wdna commented on 2018-05-09 07:35 (UTC) (edited on 2018-05-09 07:36 (UTC) by wdna)

@GPereira, I see now where it comes from, I have messed with flann a while ago related to other pages. yes it has issues and also needed to be updated, let me try to compose a working 6.4.0 package.

GPereira commented on 2018-05-08 17:39 (UTC)

The error is that flann is not linking LZ4 correctly

GPereira commented on 2018-05-08 17:38 (UTC)

Do you want to help me to correct that error on flann if I make you a co-mantainer?

GPereira commented on 2018-05-08 17:37 (UTC)

that's a know bug, I think I will rollback to 6.3.0 since it is throwing an error with flann

wdna commented on 2018-05-08 16:36 (UTC)

huh? no, that can't be the case, I tried again test #40 fails for some reson still:

40/40 Test #40: test_NearestNeighbor ..............***Not Run 0.00 sec

I tried again wiht --nocheck flag and the raw PKGBUILD file, and it worked. I also noticed the "Sources" say v6.4.0 while package build file is: pkgver=6.3.0 maybe this is the issue?

Cause then I tried building 6.4.0 with same adjusted buildfile, and got : CMakeFiles/dart-planning.dir/RRT.cpp.o: In function flann::serialization::SaveArchive::initBlock()': RRT.cpp:(.text._ZN5flann13serialization11SaveArchive9initBlockEv[_ZN5flann13serialization11SaveArchive9initBlockEv]+0x4a): undefined reference toLZ4_resetStreamHC' CMakeFiles/dart-planning.dir/RRT.cpp.o: In function flann::serialization::SaveArchive::flushBlock()': RRT.cpp:(.text._ZN5flann13serialization11SaveArchive10flushBlockEv[_ZN5flann13serialization11SaveArchive10flushBlockEv]+0x45): undefined reference toLZ4_compress_HC_continue' RRT.cpp:(.text._ZN5flann13serialization11SaveArchive10flushBlockEv[_ZN5flann13serialization11SaveArchive10flushBlockEv]+0xed): undefined reference to LZ4_compress_HC_continue' CMakeFiles/dart-planning.dir/RRT.cpp.o: In functionflann::serialization::LoadArchive::decompressAndLoadV10(_IO_FILE)': RRT.cpp:(.text._ZN5flann13serialization11LoadArchive20decompressAndLoadV10EP8_IO_FILE[_ZN5flann13serialization11LoadArchive20decompressAndLoadV10EP8_IO_FILE]+0xe6): undefined reference to LZ4_decompress_safe' CMakeFiles/dart-planning.dir/RRT.cpp.o: In functionflann::serialization::LoadArchive::loadBlock(char, unsigned long, _IO_FILE)': RRT.cpp:(.text._ZN5flann13serialization11LoadArchive9loadBlockEPcmP8_IO_FILE[_ZN5flann13serialization11LoadArchive9loadBlockEPcmP8_IO_FILE]+0x47): undefined reference to LZ4_decompress_safe_continue' CMakeFiles/dart-planning.dir/RRT.cpp.o: In functionflann::serialization::LoadArchive::initBlock(_IO_FILE)': RRT.cpp:(.text._ZN5flann13serialization11LoadArchive9initBlockEP8_IO_FILE[_ZN5flann13serialization11LoadArchive9initBlockEP8_IO_FILE]+0xbb): undefined reference to LZ4_setStreamDecode' CMakeFiles/dart-planning.dir/RRT.cpp.o: In functionflann::serialization::LoadArchive::preparePtr(unsigned long)': RRT.cpp:(.text._ZN5flann13serialization11LoadArchive10preparePtrEm[_ZN5flann13serialization11LoadArchive10preparePtrEm]+0xbd): undefined reference to `LZ4_decompress_safe_continue' collect2: error: ld returned 1 exit status make[2]: [dart/planning/CMakeFiles/dart-planning.dir/build.make:138: lib/libdart-planning.so.6.4.0] Error 1 make[1]: [CMakeFiles/Makefile2:1146: dart/planning/CMakeFiles/dart-planning.dir/all] Error 2

GPereira commented on 2018-05-07 19:06 (UTC)

it seems you are trying to access a file that is locked by other process (for example other command, or application)

wdna commented on 2018-04-30 08:14 (UTC) (edited on 2018-04-30 08:16 (UTC) by wdna)

Hey, I'm getting this:

Running tests...

Test project /var/cache/pacman/pkg/libdart19729/libdart/src/dart-6.3.0-build Start 1: test_Building

Could not find executable /var/cache/pacman/pkg/libdart19729/libdart/src/dart-6.3.0-build/bin/tests/comprehensive/test_Building

Looked in the following places:

...