Package Details: lightspark-git test_travis.r6.gaba3311a-1

Git Clone URL: https://aur.archlinux.org/lightspark-git.git (read-only)
Package Base: lightspark-git
Description: An open source flash player implementation
Upstream URL: http://lightspark.sourceforge.net
Licenses: LGPL3
Conflicts: lightspark
Provides: lightspark
Submitter: heftig
Maintainer: Alad
Last Packager: Alad
Votes: 119
Popularity: 0.012932
First Submitted: 2010-05-18 17:00
Last Updated: 2019-08-01 13:10

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

dWolf commented on 2011-07-20 15:33

current lightsparc-git don't work with the arch's ffmpeg package. For me it just crashes on youtube or vimeo.

td123 commented on 2011-02-02 18:18

librtmp is a new dependency for lightspark, I don't think there is a package for it

td123 commented on 2011-02-02 05:02

Hello, I'm getting the following error when building this package; http://pastie.org/1520530

anoknusa commented on 2011-01-18 21:29

I haven't had any problem building Lightspark; however, YouTube videos state that the plugin is outdated. Replacing it with flashhplugin-prerelease takes care of this, but I'd rather go to OSS route. Any idea why this is? I didn't see anything mentioned on the Lightspark homepage or Launchpad.

td123 commented on 2011-01-05 18:29

I have worked through getting lightspark to correctly build http://projects.archlinux.org/svntogit/community.git/tree/lightspark/trunk/PKGBUILD
You can really just copy+paste the code, but it does need to be statically linked against libxml++ 2.33.1 or it has to depend on that version (which no package exists for it right now)
Otherwise if you don't, there will be lots of random crashes related to libxml++.

td123 commented on 2010-11-08 20:57

This package fails to compile, please see the lightspark PKGBUILD to see how it is worked around there.

cookiecaper commented on 2010-11-07 09:44

See the following thread:
http://groups.google.com/group/llvm-dev/browse_thread/thread/ca747ca9c750ca26/dc50cd293ee3efc7?show_docid=dc50cd293ee3efc7

It appears that LLVM 2.8 has an incompatibility with GCC 4.5 and will sometimes cause this error. It is fixed in LLVM SVN, so you'll either need to upgrade to LLVM SVN or downgrade to 2.7. The guys in #llvm say that they usually don't do point releases.

Anonymous comment on 2010-10-19 08:38

Ftr, this package apparently won't compile with the current LLVM (2.8). You need to revert to 2.7 for it to compile.

Anonymous comment on 2010-10-15 19:31

fails in compilation

http://pastebin.com/075ZnE8J

td123 commented on 2010-09-25 04:37

Ya, libxml++ was recently used to handle security policies in flash. please add libxml++ to the depends array