Package Details: ffmpeg-intel-full-git 6.1.r110779.g82278e8749-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-intel-full-git.git (read-only, click to copy)
Package Base: ffmpeg-intel-full-git
Description: Complete solution to record, convert and stream audio and video (all possible features for intel; git version) (based on dbermond package)
Upstream URL: https://www.ffmpeg.org/
Keywords: audio codec convert decklink encoder fdk-aac fdkaac ffmpeg ffmpeg-git hwaccel intel-svt libnpp media qsv quicksync vaapi video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg
Provides: ffmpeg, ffmpeg-full, ffmpeg-git, ffmpeg-intel, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: arllk
Maintainer: fbrennan
Last Packager: fbrennan
Votes: 10
Popularity: 0.067344
First Submitted: 2019-12-09 20:07 (UTC)
Last Updated: 2023-05-26 07:13 (UTC)

Dependencies (109)

Required by (1840)

Sources (8)

Latest Comments

1 2 3 Next › Last »

zertyz commented on 2023-12-24 02:08 (UTC)

Can´t currently build:

$ makepkg -s
(...)
Cloning into bare repository '/home/luiz/tmp/ffmpeg-intel-full-git/ffmpeg'...
(...)
patching file fftools/opt_common.c
Hunk #1 succeeded at 196 (offset 3 lines).
Hunk #2 succeeded at 204 (offset 3 lines).
patching file configure
Hunk #1 FAILED at 291.
Hunk #2 succeeded at 1895 (offset 43 lines).
Hunk #3 succeeded at 3491 (offset 86 lines).
Hunk #4 succeeded at 6856 (offset 176 lines).
1 out of 4 hunks FAILED -- saving rejects to file configure.rej
patching file libavcodec/Makefile
Hunk #1 succeeded at 1155 with fuzz 1 (offset 29 lines).
patching file libavcodec/allcodecs.c
Hunk #1 FAILED at 812.
1 out of 1 hunk FAILED -- saving rejects to file libavcodec/allcodecs.c.rej
patching file libavcodec/libsvt_hevc.c
==> ERROR: prepare() failed

bezirg commented on 2023-10-27 11:25 (UTC)

Thank you for this package.

@kode54 I would also be interested in an AV1 enabled version of this package.

muqeshem commented on 2023-09-10 08:20 (UTC) (edited on 2023-09-10 08:21 (UTC) by muqeshem)

I am trying to build the package but I got this error.

kode54 commented on 2023-07-17 01:54 (UTC) (edited on 2023-07-17 01:55 (UTC) by kode54)

I’m considering forking this to create a minor variant, one which enables libvpl instead of libmfx, as is necessary to get AV1 encode support on Arc cards. I intend to otherwise keep it in sync with anything this one changes otherwise, so they’re both otherwise identical.

Edit: Dang, that’s a lot of otherwise.

fbrennan commented on 2023-05-26 07:08 (UTC)

Well, I'm building now v6.1.r110779.g82278e8749-1.

fbrennan commented on 2023-05-26 07:07 (UTC)

Strange. Perhaps reversions upstream.

TurnoffNOD commented on 2023-05-25 03:30 (UTC) (edited on 2023-05-25 03:30 (UTC) by TurnoffNOD)

Hi, this PKGBUILD set pkgver to 6.1.r110759.gd815584755-1, however here say the version is 6.1.r110700.ge684967e74-1, so yay -Syuu will output:

:: 7 packages to upgrade/install.
7  aur/ffmpeg-intel-full-git    6.1.r110759.gd815584755-1 -> 6.1.r110700.ge684967e74-1
6  aur/lensfun-git              0.3.2.r2657.g16db4045-1   -> 0.3.2.r2592.gec9412d2-1
5  aur/libklvanc-git            r553.87d9525-1            -> r434.d474cfc-1
4  aur/liquid-dsp-git           v1.5.0.r70.g41507de1-1    -> v1.3.1.r134.gdd3facf8-1
3  aur/oss-cad-suite-build-bin  20230422-1                -> 20230524-1
2  aur/riscv-pk-git             r600.3ed18cf-1            -> 1-1
1  aur/uavs3d-git               1.1.r47.g1fd0491-1        -> 1.1.r40.g818a0cb-1

This is a downgrade.

fbrennan commented on 2023-05-22 00:05 (UTC)

Fixed in latest by no longer relying on OpenVisualCloud/SVT-HEVC for SVT-VP9 support.

Fifis commented on 2023-05-18 13:19 (UTC)

Build failed:

libavcodec/Makefile:1127: *** missing separator (did you mean TAB instead of 8 spaces?).  Stop.
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'ffmpeg-intel-full-git-6.1.r110537.g1eed7f6562-1': 

fbrennan commented on 2023-05-08 17:28 (UTC) (edited on 2023-05-08 17:28 (UTC) by fbrennan)

Thanks éclairevoyant! Unfortunately, no cause for celebration, as v5 is not supported by asr filter anyway :(

@@ -65,6 +71,10 @@ prepare() {
     patch -d ffmpeg -Np1 -F2 -i "${srcdir}/020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"
     patch -d ffmpeg -Np1 -F3 -i "${srcdir}/030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
     patch -d ffmpeg -Np1 -F3 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
+    # ffmpeg is as yet incompatible with pocketsphinx 5.0.
+    # Let me know if this changes.
+    # libavfilter/af_asr.c:42:5: error: unknown type name ‘cmd_ln_t’ (etc)
+    #patch -d ffmpeg -Np1 -F3 -i "${srcdir}/050-ffmpeg-pocketsphinx-arch.patch"
 }